Skocz do zawartości
blint

mySantos.pl | GitHub

Rekomendowane odpowiedzi

I wychodzi plus 50 zł za PhpMyAdmin, dziękuję.

 

Co do mojego problemu... Zreinstalowałem całego VPS'a i teraz spróbuję zrobić po kolei tak, żeby działało.

 

//edit: Ma ktoś jakiś pomysł...?

Edytowane przez cycek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Z forum SA-MP.com pobierz świeży plugin mysql.so :) lub Klik

 

Stary, dzięki, działa! :D

Tylko teraz nadal się nie chce GameMode uruchomić :/ Może źle konfiguruję połączenie MySQL w GameMode'dzie?

Robię to tak:

#define M_HOST "localhost" //Tutaj nie wiem czy tak ma być.
#define M_LOGIN "ourdecis_gracze" //Tutaj daję użytkownika bazy danych.
#define M_PASS "hasło" //Hasło użytkownika bazy danych.
#define M_DB "ourdecis_dane" //Nazwa bazy danych

 

Serverlog:

----------
Loaded log file: "server_log.txt".
----------


SA-MP Dedicated Server
----------------------
v0.3z-R4, (C)2005-2014 SA-MP Team


[08:38:24] 
[08:38:24] Server Plugins
[08:38:24] --------------
[08:38:24]  Loading plugin: mysql.so
[08:38:24] 


  > MySQL plugin R5 successfully loaded.


[08:38:24]   Loaded.
[08:38:24]  Loading plugin: streamer.so
[08:38:24]   Loaded.
[08:38:24]  Loading plugin: sscanf.so
[08:38:24] 


[08:38:24]  ===============================


[08:38:24]       sscanf plugin loaded.     


[08:38:24]          Version:  2.8.1        


[08:38:24]    (c) 2012 Alex "Y_Less" Cole  


[08:38:24]  ===============================


[08:38:24]   Loaded.
[08:38:24]  Loading plugin: FileFunctions.so
[08:38:24]   Loaded.
[08:38:24]  Loading plugin: audio.so
[08:38:24] 


*** Audio Plugin v0.5 R2 by Incognito loaded ***


[08:38:24]   Loaded.
[08:38:24]  Loaded 5 plugins.


[08:38:24] 
[08:38:24] Filterscripts
[08:38:24] ---------------
[08:38:24]   Loading filterscript 'PalominoC.amx'...
[08:38:24]   Loaded 1 filterscripts.


[08:38:24] Script[gamemodes/vliveb.amx]: Run time error 19: "File or function is not found"
[08:38:24] Number of vehicle models: 0

PS.: Baza danych stoi na xaa.pl.

 

//edit:

Zainstalowałem plugin "nativechecker.so" i teraz w serverlog mam dodatkowe trzy błędy pokazane:

 

[10:40:46]    Error: Function not registered: 'mysql_fetch_row'
[10:40:46]    Error: Function not registered: 'mysql_fetch_string'
[10:40:46]    Error: Function not registered: 'mysql_init'
Edytowane przez cycek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No to ja już nie wiem... Gdy zainstaluję ten od Soczka to przynajmniej normalnie mi mysql.so czyta, ale wywala mi te trzy błędy :/ Gdy zainstaluję plugin mysql.so, ale stąd to jest ten błąd:

Failed (libmysqlclient_r.so.16: cannot open shared object file: No such file or directory)

No to co mam zrobić? Bo ja już nie wiem :/

Edytowane przez cycek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No to ja już nie wiem... Gdy zainstaluję ten od Soczka to przynajmniej normalnie mi mysql.so czyta, ale wywala mi te trzy błędy :/ Gdy zainstaluję plugin mysql.so, ale stąd to jest ten błąd:

Failed (libmysqlclient_r.so.16: cannot open shared object file: No such file or directory)

No to co mam zrobić? Bo ja już nie wiem :/

Problem wałkowany od tysiąc lat, po prostu zaopatrz się w tę bibliotekę. Ściągnij plik libmysqlclient.so.16 i zmień jego nazwę na libmysqlclient_r.so.16 i dopiero po wrzuceniu go do /usr/lib możesz odpalić ten "skrypt"..  :wacko:

Edytowane przez Dwarg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem wałkowany od tysiąc lat, po prostu zaopatrz się w tę bibliotekę. Ściągnij plik libmysqlclient.so.16 i zmień jego nazwę na libmysqlclient_r.so.16 i dopiero po wrzuceniu go do /usr/lib możesz odpalić ten "skrypt"..  :wacko:

 

DZIĘKI! Wszystko działa! Teraz w serverlog wyskakują błędy związane z podłączeniem do bazy danych, ale to sobie już naprawię :P Dzięki jeszcze raz wszystkim!

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Cześć. Otóż mam taki problem. Wrzuciłem wszystkie pliczki itd. na VPSa, podłączyłem pod IPB. Loguje się na stworzoną postać i wszystko działa. Paczka bardzo fajna. Jednak jak zalogowałem się na /duty programisty, moderatora (na innych nie sprawdzałem) to nie działają mi niektóre z komend dla administracji. Mówie tu o np. /aprzedmiot, nie wiem też za bardzo jaka jest komenda na teleport. Dodam, że CMD takie jak /fly, /spec, /bw działają normalnie. Pozdrawiam i proszę o pomoc.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam błędy następujące, oto log :

 

 

 

 
----------
Loaded log file: "server_log.txt".
----------
 
SA-MP Dedicated Server
----------------------
v0.3z, ©2005-2014 SA-MP Team
 
[11:39:42] 
[11:39:42] Server Plugins
[11:39:42] --------------
[11:39:42]  Loaded 0 plugins.
 
[11:39:42] 
[11:39:42] Filterscripts
[11:39:42] ---------------
[11:39:42]   Loading filterscript 'gl_actions.amx'...
[11:39:42]   Loading filterscript 'gl_realtime.amx'...
[11:39:42]   Loading filterscript 'gl_property.amx'...
[11:39:42] 
-----------------------------------
[11:39:42] Grand Larceny Property Filterscript
[11:39:42] -----------------------------------
 
[11:39:42]   Loading filterscript 'gl_mapicon.amx'...
[11:39:42]   Loading filterscript 'ls_mall.amx'...
[11:39:42]   Loading filterscript 'ls_elevator.amx'...
[11:39:42]   Loading filterscript 'attachments.amx'...
[11:39:42]   Loading filterscript 'skinchanger.amx'...
[11:39:42] 
--Admin Player Skin Changer Loaded
 
[11:39:42]   Loading filterscript 'vspawner.amx'...
[11:39:42] 
--Admin Vehicle Spawner Loaded
 
[11:39:42]   Loaded 9 filterscripts.
 
[11:39:42] Reading File: blank
[11:39:42] Reading File: properties/houses.txt
[11:39:42] Reading File: properties/businesses.txt
[11:39:42] Reading File: properties/banks.txt
[11:39:42] Reading File: properties/police.txt
[11:39:42] Script[gamemodes/vliveb.amx]: Run time error 19: "File or function is not found"
[11:39:42] Number of vehicle models: 0
 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Cześć. Otóż mam taki problem. Wrzuciłem wszystkie pliczki itd. na VPSa, podłączyłem pod IPB. Loguje się na stworzoną postać i wszystko działa. Paczka bardzo fajna. Jednak jak zalogowałem się na /duty programisty, moderatora (na innych nie sprawdzałem) to nie działają mi niektóre z komend dla administracji. Mówie tu o np. /aprzedmiot, nie wiem też za bardzo jaka jest komenda na teleport. Dodam, że CMD takie jak /fly, /spec, /bw działają normalnie. Pozdrawiam i proszę o pomoc.

 

Nadal proszę o pomoc. :) Już gites, kolega się zajął tym błędem. Uprawnienia nie były po prostu odpowiednio zrobione.

Edytowane przez Fragum

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam problem z zalogowaniem się, ciągle komunikat o błędnym haśle. GID z tabeli ipb podane, czy mógłby mi ktoś podać przykładową postać z core_players dla porównania?

 

//naprawione - nie zmieniłem tabeli members w skrypcie

Edytowane przez davidson

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam, problem ciągle pojawia mi się, że nie prawidłowe hasło, czy da się jakoś temu zaradzić ? Char_gid wpisałem. i dalej nic a na pewno łaczy się dobrze z bazą.

Jak trzeba dam na pw, dane do bazy, i jakby ktoś mógł sprawdzić czy wszystko ok.

Edytowane przez knapek14

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Właśnie nie, przeznaczyłem na ten skrypt niecałe 3 godziny i jestem w stu procentach przekonany, że gdy go będę rozwijał mogę stworzyć własny projekt, ale po co, co mi to da. // Bugi na hajs też naprawiłem.

Edytowane przez Adwokat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
[MySQL] Error (0): Failed to exeute query. You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NULL' at line 1.

Nie wie ktoś może jak to naprawić? Bardzo zaśmieca logi....

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

PRzecież robię to w pawno.

 

Taka mała rada ode mnie. Odstaw komputer i wszelkie gry w kąt, wróć się do szkoły podstawowej w celu nauczenia się czytania ze zrozumieniem, gdzie w programowaniu jest to podstawa, a Ty najwidoczniej masz jakieś ubytki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×