Skocz do zawartości
ViperX

[ROZWIĄZANY]SERVER: Unknow command

Rekomendowane odpowiedzi

Ja mam tak i ładnie działa

public OnPlayerCommandPerformed(playerid, cmdtext[], success)
{
    if(!success)
    {
    SendClientMessage(playerid, siwy, "System nie odnalazł wpisanej przez ciebie komendy!");
    return 1;
    }
    return 1;
}

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
1 godzinę temu, ViperX napisał:

Mam kolejny problem, tym razem z komendami. Jak wpisze komendę która istnieje np. /cars to pokazuję się na czacie Server: unknow command po czym pojawia się to co ma siępojawić xD.

Przejdź na ZCMD prostszy i szybszy.

Pobierasz wtyczkę ZCMD, i przykład użycia:

CMD:xd(playerid, params[])

{

if(IsPlayerConnected(playerid))return SendClientMessage(playerid, -1, "xD");

}

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ale to nie oto chodzi. Chodzi oto że jak dodałem ten podgląd do tego publica to wtedy coś sie zaczeło pierdzielić. Na przykład wcześniej normalnje komęda /cars działała. Podobnie jest jak wpiszę komęde która nie istnieje np. /hshdjjdjsjd to wtedy na czacie pokazuję się moja wiadomość czyli. Nie ma takiej komendy. Wpisz /help aby uzyskać pomoc oraz pokazuję się server: unknow command 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

typowe pomaganie na siłe :D

OnPlayerCommandPerformed musi dostać return 1; aby nie pokazał Unknown Command, wystarczy, że dodasz go na końcu swojego kodu i będzie oki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×