Skocz do zawartości
Zerfet

Logowanie nie działa

Rekomendowane odpowiedzi

Witam. Mam taki problem ze stronką na domenie z mintshost. Nie działa mi logowanie. Dodam, że na vps mi wszystko poprawnie działało. Jak chcę się zalogować to na gorze strony wyskakują takie błędy:

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/pmtruckp/domains/xxx.pl/public_html/login.php:1) in /home/pctruckp/domains/xxx.pl/public_html/login.php on line 1

Notice: Undefined index: loggined in /home/pctruckp/domains/xxx.pl/public_html/login.php on line 4

Notice: Undefined index: login in /home/pctruckp/domains/xxx.pl/public_html/login.php on line 22

Notice: Undefined index: haslo in /home/pctruckp/domains/xxx.pl/public_html/login.php on line 26

Warning: Cannot modify header information - headers already sent by (output started at /home/pmtruckp/domains/pmtruck.pl/public_html/login.php:1) in /home/pctruckp/domains/xxx.pl/public_html/login.php on line 57

Linia 1 i 2 z login.php:

 

<? session_start();

	include ('config.php');

 

Linia 4, 5, 6 i 7:

 

if($_SESSION['loggined'] == 1)

	{

	header("Location: panel.php");

	}

 

Linia 22-26:

 

if ($_GET['login'] != '') { //jezeli ktos przez adres probuje kombinowac

	header("Location: login.php?nieudane=1");

	exit;

	}

	if ($_GET['haslo'] != '') { //jezeli ktos przez adres probuje kombinowac

 

Linia 27, 28 i 29:

 


 

header("Location: login.php?nieudane=1"); exit; }

 

 

Linia 57:

 

header("Location: panel.php");

 

Nie mam pojęcia o co chodzi. Na VPS wszystko było git a tu nie. Wie może ktoś co jest nie tak?

 

EDIT: Dodam jeszcze, że po tym jak nas nie zalogowało właśnie przez te błędy to jak wyjdziemy ze stronki i jeszcze raz na nią wejdziemy to jesteśmy zalogowani i nie ma ani jednego warninga.

EDIT2: Zauważyłem teraz, że nie tylko coś nie tak z logowaniem jest ale rownież w jednej podstronie są rozciągnięte niektore rzeczy, że od gory aż na sam doł idą. To wina kodu raczej nie jest bo na vps wszystko działało poprawnie więc co może być powodem tych błędów?

Edytowane przez Zerfet

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×